Misnomer: List Interface

Some think “List” is a misnomer. I don’t even mind so much. I think List is ok.

I just put this here because there already is an entry in the FAQ:

Why don’t you rename the List interface to Sequence; doesn’t “list” generally suggest “linked list”? Also, doesn’t it conflict with java.awt.List?

PS: Vector is strange, though. It is synchronized and it really should be SynchronizedList. But it is defacto deprecated. So who cares?

Leave a Reply

Your email address will not be published.